Synology License and installation wizard not shown when installing Synology Package

I noticed this morning that my Synology is not showing the License and the Installation Wizard anymore when installing my own Packages (Packages made with my app MODS and hosted on my own SSPK Server).

Click to Read More

I am not yet able to understand why the Installation Wizards and the Licence file of my own packages are not shown anymore, when installing them from my SSPK server via “Package Center” > “Community”. But everything works fine when installing them “Manually” via “Package Center” > “Manual Install” (and browsing to pick the spk into the folder of my SSPK server).

The Upgrade Wizards and even the “Confirm settings” screen are also not displayed… While the Uninstallation Wizard works fine in all cases ?!

My DS1815+ is running DSM 6.1.7-15284.

I have compared all the logs created in /var/log/ during the installation and noticed a few differences. First, when installing a package from my SSPK server, there are ‘messages’ being logged:

2018-11-03T22:26:05+01:00 … synoscgi_SYNO.Core.Package.Installation_1_install[21663]: resource_api.cpp:163 Acquire service-cfg for [the package I am installing] when 0x0001 (done)

This is logged each time I am installing a package from my SSPK Server but not when install the same package manually.

Next to those messages, the following INFO are also logged in synofeasibilitycheck.log:

2018-11-03T22:25:50+01:00 … synoscgi_SYNO.Core.Package_1_feasibility_check[21529]: feasibility_check.cpp:87 FeasibilityCheck: [Info] Start feasibility check [package_install] with type [hard].
2018-11-03T22:25:50+01:00 … synoscgi_SYNO.Core.Package_1_feasibility_check[21529]: feasibility_check.cpp:106 FeasibilityCheck: [Info] [0] of feasibility check [package_install] failed.
2018-11-03T22:25:50+01:00 … synoscgi_SYNO.Core.Package_1_feasibility_check[21529]: feasibility_check.cpp:79 FeasibilityCheck: [Info] No [package_install] feasibility check config with type [soft].