JBL Link 20 and 300 having crunchy, crackling, static pop noise

Since I am using a mesh network (based on TP-Link Deco M9 plus) I started to have more and more crackling noise on both my JBL Link 20 and 300, even if located very close to the repeaters. The only solution is to reset the JBL.

Click to Read More

It's a very common issue, due to the "Wifi stability", not only experienced with the TP-Link Deco M9 Plus (quich are actually quite good for their purpose) and even not only with the JBL (Read these posts).

I have read a lot of posts on this issue and none could help. it has been useless to update the firmware, to open the devices and apply the tricks and tips found on the web, ...

The only trick, which work immediatly, is to reset the JBL and reconfigure it in Google Home. Next, it works like a charm.. for quite some time (months in my case)... but at the end, the crackling noise come back and you have to reset again.

To reset the JBL Link 300, hold both the "Bluetooth" and the "Volume up" buttons for up to 20 seconds (until you see the "Mute" button becoming orange) as ilustrated on the video here after. Next wait until you the JBL has rebooted and open Google Home to reconfigure it.

To reset the JBL Link 20, hold the "Mute" button for up to 10 sec until the Wifi led switch off. Next hold both the "Mute" and "Power" buttons for about 20 seconds (until it restarts) as ilustrated on the video here after. Next wait until you the JBL has rebooted and open Google Home to reconfigure it.

Leave a Reply

Your email address will not be published. Required fields are marked *