Upgrade from DSM 4.3 to DSM 5.0

Wow, what a fancy look & feel !!! That's my first impression  :-D

But what I really care about, is that all the services I was using on DSM 4.3 are still running fine... And it seems to be the case once a few issues fixed...

Click to Read More

After the upgrade, various packages had to be updated. Unfortunately, the updates did not all passed successfully. I got errors like "failed to download" (notice: I did an update of all my packages before upgrading from DSM 4.3 to 5.0 as recommended by users on Synology's forum)

I discovered soon that I was actually unable to download and install any other packages. And looking into Control Panel > Update & Restore, I saw the Status "Connection failed. Please check your Internet connection".

I  was unable to play Internet radio within the Audio Station and trying to "Update Now" the DDNS service (Control Panel > External Access > Update Now), I was receiving a message like "Network error occurred. Please check your DNS and network settings."

As Download Station was still able to download, the internet connection was not the issue. So, based on the hypothesis that it should be a DNS issue, I did force a DNS address manually in Control Panel > Network > General > Manually configure DNS Server. I did set the IP of my Adsm Modem as it's configured to forward DNS request to my provider. But I could have tried with Google's DNS: 8.8.8.8 or 8.8.8.4

And it solved all the issues above ?!

As a reminder, my DHCP server is configured on my Buffalo Router to provide the IP of my NAS as a DNS Server (I run the "DNS Server" package of Synology) and the IP of my ADSL model as a fallback. It used to work fine before the upgrade and as I didn't change anything else in my infra, I thought that some behavior could have change in some Syno's services. I did try various changes and found one that was solving the issues without manual configuration of a DNS IP on my Syno:

I had to "Enable resolution services" in my Synology's "Control Panel > DNS Server > Resolution" settings. Simple, no ?

But I discovered then another issue: my Plex Server was not accessible anymore (when opened from DSM's start menu). It was trying to start on the IP address of an unused Ethernet port - There are two Ethernet ports on the DS713+ and only the second one of mine was plugged on my Switch. The IP used by Plex Server was therefore a default one: 169.254.x.x. So, I did connect the first Ethernet ports on my Switch and did a reboot. I was next able to access the Web UI on the IP assigned now to my NAS's first Ethernet port.

But it was not solving everything. Indeed, plex.tv was still not able to reach my NAS since my ADSL Modem was forwarding the default port of Plex (32400) onto the IP of the second Ethernet port and not on the first one (I.e.: on the IP Plex Server was actually listening on). As my NAS is only connected to one LAN, I decided to enable the Link Aggregation to merge the two ports into a "virtual single one". Doing so, I would have only one IP assigned to my NAS and both Ethernet port used together to increase a bit the bandwidth: Control Panel > Network > Network Interface > Create > Create Bond > IEEE 802 Dynamic Link Aggregation. I did complete the Wizard (using DHCP the get an IP) and went to reconfigure my DHCP server (on my Buffalo Router): I.e.: I did update the static leases and assigned the static IP wanted for my NAS on the MAC address currently used by the Dynamic Link Aggregation (It's available in the Control Panel > Info Center > Network > Bond 1).

Once the DHCP server and the Synology reconfigured, I did reboot both (to avoid caching effect). Unfortunately, when accessing my server via plex.tv, it was still not displayed as "online" :( Also, in the "Plex Media Server"'s settings "myPlex", I was unable to connect with my login/password and worst, I was unable to change any settings in my Plex Server: Saving changes was always failing... I found a note about a known issue on the Synology website:

DSM 5.0: Known Issue - Plex Media Server
Users need to manually set read permission for the “plex” user at the User page in Control Panel to allow Plex Media Server to read the shared media folder content.

But trying this fix didn't solve my issues.

I thought then that there could be a more recent version of the Plex Server on plex.tv than on Synology... And indeed. The version I had was 9.8 and there was a 9.9 on Plex.tv. I did download the spk for my processor (DS713+ = Intel) and did install it manually. And Bingo, my Plex Media Server was now able to connect to myPlex and it appeared as "Online" in plex.tv !!!

So, to conclude, the following services are now running fine:

    • Download Station (it resumes the download of your the torrent without any issue)
    • Surveillance Station (the time line is not broken)
    • DNS Server (once the "Resolution Service" enabled as mentioned above)
    • Video Station (has been updated)
    • Photo Station (has been updated)
    • Webalizer (has been updated)
    • Plex  (After a manual update as mentioned above and some reconfiguration of the IP/Ethernet port used)
    • WordPress (has been updated)
    • phpMyAdmin

Changes I noticed:

  • As usually, after the upgrade of WordPress (If you do so), you will have to reset the permalinks' format (via Dashboard > Settings > Permalinks > Common Settings > re-select your structure and "Save Changes"). Otherwise, links to your posts (E.g.: found via google or kept as favorites by readers) won't work anymore..
  • The DDNS service is now named "External Access". Nothing has changed and nothing needs to be reconfigured.
  • MySQL has been replaced by MariaDB (a fork of the original project). Start it once to finalize the update (you will have to provide your password). phpMyAdmin still runs fine and connects automatically to MariaDB with your current root login and password.
  • You will now get a monthly report by email with the status of the disks. Ex.:

Dear user,

The following is your monthly report regarding the health of disks on <serverName>. You can also check the health of individual disks at Storage Manager > HDD/SSD > Health Info.

Disk 1:

Disk Reconnection Count 0

Bad Sector Count 0

Disk Re-identification Count 0

Disk 2:

Disk Reconnection Count 0

Bad Sector Count 0

Disk Re-identification Count 0

One thought on “Upgrade from DSM 4.3 to DSM 5.0

  1. Thanks for sharing. I'm looking at upgrading our diskstation to the 5.0 version and it helps to see what you went through for when I have to deal with the same stuff. It seems straight forward with a possible 1 or 2 hiccups.

Leave a Reply

Your email address will not be published. Required fields are marked *